help.axcms.netAxinom Logo
Save Save Chapter Send Feedback
KB10026: ASP.NET framework cannot be configured for the virtual directories
If .NET framework is installed before IIS is, you may encounter problems

SYMPTOMS

It is not possible to choose the needed ASP.NET framework for your virtual directory in IIS. This again causes errors loading the pages.

CAUSE

.NET framework is installed before IIS is.

On IIS5/6 based systems (Windows XP, Windows Server 2003) by default .NET Framework 2.0 / 3.5 are missing. When you install it and if IIS is present then installation should integrate the .NET 2.0 / 3.5 support for Web Applications. As these versions of Windows were released before Framework 2/3, they can’t integrate the Framework to IIS when you install the IIS role after Framework installation. It means that Framework 2.0/3.5 seems to be installed but you can’t choose it for IIS Web Sites.

SOLUTION

Reinstall .NET Framework, you can use the tool “aspnet_regiis.exe" for that purpose.

MORE INFORMATION

Framework 3.5 is expansion for Framework 2.0. So when 3.5 is installed then you choose anyway 2.0 version for IIS Web Site and integrate it to IIS the same way as you integrate 2.0 version (on IIS6 based systems).

Read also: http://msdn2.microsoft.com/en-us/library/k6h9cz8h(VS.80).aspx

APPLIES TO

IIS versions: 5.x, 6.0

AxCMS.net versions: All versions